Location accuracy setting can’t be changed
Last updated October 21st, 2024
Categories:
Environment
- Knox Manage
- Knox Mobile Enrollment
- Devices running Android 14 or lower
Overview
Device users may notice that the Location Accuracy setting on the device is turned off and in a disabled state, despite the Android Enterprise Location Settings policy being set to Force on through Knox Manage.
Cause
Despite the Location Settings policy being set to Force on, Android requires that the device user provides permission to use device location by clicking Accept on the Google services screen.
If users are unable to view the Google services screen, the Location Accuracy setting on the device is turned off and in a disabled state by default.
When enrolling devices using Knox Mobile Enrollment, the behavior of the Google services screen is dependent on your Android version:
- For devices running Android 14, if Enrollment screens > Show the setup Wizard after EMM enrollment is deselected, the Google services screen doesn’t appear.
- For devices running Android 13, the Google services screen doesn’t appear regardless of the value of Show setup Wizard after EMM enrollment.
- For company owned devices with work profiles, the Google services screen doesn’t appear if the Show the setup Wizard after EMM enrollment setting is deselected for devices running either Android 13 or Android 14.
Resolution
For devices running Android 14 or lower, you can temporarily change the value of Location Settings in the Knox Manage console:
-
In the Knox Manage console, click Profile.
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Select your existing profile and click Modify Policy.
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Under the Android Enterprise policy drawer, select Location.
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Modify the following policies:
Policy Value Location Settings Allow user to configure and prompt for location accuracy -
Click Save & Assign > OK to save and push your changes to your device fleet.
When the device user taps Accept on the Google services screen, the Location Accuracy setting on the device is re-enabled.
After the Location Accuracy setting is enabled on the device, you can revert the Location Settings back to Force on in the Knox Manage console.
Alternatively, for devices running Android 14, you can do the following. However, this requires a factory reset.
- In your existing Knox Mobile Enrollment profile, click Standard settings > Edit.
- Under Enrollment screens, select Show the setup wizard after EMM enrollment.
- Click NEXT > SAVE.
After that, proceed to factory reset your device.
Additional Reading
For more information on Knox Mobile Enrollment profiles, visit Manage profiles.
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