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App disappears from device after reboot

Last updated November 14th, 2024

Categories:

Environment

  • Knox Manage
  • Fully managed profile
  • Devices running Android 14 and higher

Overview

Device users may encounter an issue where an installed app disappears upon rebooting. This issue occurs even though there are no app restriction policies set on the device.

Cause

The Hide Apps policy hides installed apps from the app drawer on a device.

In the case of an app that’s not yet installed and for which the Hide Apps policy is enabled and then disabled in the Knox Manage console, when you install the app and reboot the device, the app doesn’t display in the app drawer.

Google is aware of this issue and is actively investigating a resolution.

Workaround

First, you can temporarily apply the Hide Apps policy for your app:

  1. In the Knox Manage console, click Profile.

  2. Select your desired profile and click Modify Policy.

  3. Under the Android Enterprise policy drawer, click App Restrictions.

  4. Modify the following policies:

    Policy Value
    Hide Apps Apply
    Hide Apps > App List Click Add and select your app.
  5. Click OK.

  6. Click Save & Assign to push your changes to the device fleet.

Next, disable the Hide Apps policy for your app:

  1. In the Knox Manage console, click Profile.

  2. Select your desired profile and click Modify Policy.

  3. Under the Android Enterprise policy drawer, click App Restrictions.

  4. Modify the following policies:

    Policy Value
    Hide Apps > App List Remove your app.
  5. Click Save & Assign to push your changes to the device fleet.

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