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Restarted device remains stuck on the boot screen

Last updated September 19th, 2024

Categories:

Environment

  • Knox Manage
  • Android Enterprise
  • Fully managed device

Overview

After restarting a fully managed device, you may encounter an issue where the Samsung Galaxy boot screen persists on the device, and the device user is unable to proceed.

Cause

The com.android.settings package manages core Android features that are required to start the device. If the package is included in the list for the Hide Apps policy (see Android Enterprise policies), it’s prevented from running and the device is unable to start normally.

Resolution

To resolve the issue, remove com.android.settings from the Hide Apps policy:

  1. In the Knox Manage console, go to Profile .

  2. Select your target profile and click Modify Policy.

  3. Open the Android Enterprise > App Restrictions policy drawer, and modify the following policy under Hide Apps as follows:

    Policy Value
    Hide Apps > App List Remove com.android.settings.
  4. Click Save & Assign to push the profile to your device fleet.

To prevent device users from accessing the device settings:

  1. Open the Samsung Knox > System policy drawer, and modify the following policy under Settings as follows:

    Policy Value
    Settings Disallow
  2. Click Save & Assign to save your changes and push the profile to your device fleet.

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