Back to top

Knox Configure enrollment doesn’t start immediately after Knox Manage enrollment

Last updated August 23rd, 2024

Categories:

Environment

  • Knox Manage
  • Knox Configure
  • Device running Android 14 or higher
  • Kiosk mode

Overview

If a device is assigned to both a Knox Configure profile and a Knox Manage profile to create a kiosk, you may notice that the Knox Configure enrollment doesn’t start automatically after the Knox Manage enrollment is completed.

Cause

For Android 14 and higher, the app behavior when enrolling both Knox Manage and Knox Configure has changed due to deprecation of the setDefaultApplication API operation.

This API was important for Knox Configure enrollment to start on a fully managed device in the kiosk mode. Following the deprecation, the Knox Configure enrollment is unable to start immediately after the Knox Manage enrollment completes. It may take up to 15 minutes for the Knox Configure enrollment to automatically start.

Resolution

To immediately trigger Knox Configure enrollment after Knox Manage enrollment, the device user must manually restart the device.

Is this page helpful?