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Unable to recover Google Play

Last updated August 2nd, 2024

Categories:

Environment

  • Knox Manage
  • Android Enterprise
  • Fully managed device

Overview

Some device users may have the Play Store Recovery Service instead of Google Play on their device. Launching the Play Store Recovery Service results in the following status:

Please wait, recovering the Play Store…

Cause

If the Allow Uninstallation policy is set to Disallow, device users can’t recover Google Play with the Play Store Recovery Service.

Furthermore, the App Uninstallation Prevention List policy restricts a device user from updating apps on the device. If this policy includes Google Play, the app can’t update to the latest version.

Resolution

To allow device users to recover Google Play with the Play Store Recovery Service, you can set the Allow Uninstallation policy to Allow:

  1. In the Knox Manage console, go to Profile.

  2. Modify an existing profile.

  3. Open the Android Enterprise > App Restrictions policy drawer, and modify the following policy:

    Policy Value
    Allow Uninstallation Allow
  4. Click Save & Assign to push the profile to the affected devices.

If the issue persists, you must remove Google Play from the App Uninstallation Prevention List policy:

  1. In the Knox Manage console, go to Profile.

  2. Modify an existing profile.

  3. Open the Android Enterprise > App Restrictions policy drawer, and modify the following policy:

    Policy Value
    Block Certain Apps from Being Uninstalled > App List Remove com.android.vending from the list.
  4. Click Save & Assign to push the profile to the affected devices.

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