Unable to sync a user with AD/LDAP
Last updated December 18th, 2023
Categories:
Environment
- Knox Manage
- Active Directory service
Overview
You might encounter the issue where syncing a user to Knox Manage with Active Directory fails with the following error:
The user entered already exists
This error is displayed even though the user doesn’t exist in Knox Manage.
Cause
When a user is removed from Knox Manage but not from Active Directory, an attempt to update the information on the Active Directory service results in a sync conflict in Knox Manage.
Resolution
With the Knox Manage 23.12 release, a fix has been implemented. A Delete feature has been added to allow users to remove incorrect data from the Active Directory service.
To view and remove users affected by the sync issue:
- On the Knox Manage console, go to Setting > Identity & Directory > Connection.
- Under Sync Target, users affected by the sync conflict are displayed in red. Select all the affected users.
- Click Delete to remove the affected users from Knox Manage.
- Re-sync the users to the Knox Manage console with Active Directory.
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