How to connect locked devices to the Internet

Last updated November 14th, 2025

Categories:

Environment

  • Knox Guard

Overview

By default, Knox Guard activated devices maintain Wi-Fi and mobile data connectivity to receive and process commands with the Knox Guard server. However, you may experience some trouble connecting to the Internet on locked devices.

Cause

When a device is locked by Knox Guard, it follows certain connectivity parameters.

If a device is locked by Knox Guard and Wi-Fi or mobile data is deactivated, the Wi-Fi and mobile data icons remain visible on the lock screen, allowing you to see the connectivity status. However, once you enable network connections on the device, the icons disappear. The device only connects to Wi-Fi networks that were previously configured or connected to prior to being locked. If no Wi-Fi network is available, the device may connect to mobile data instead.

As a result, connectivity icons only display on locked devices when network services are disabled. Once network connectivity is enabled, the icons disappear, but the device only connects to pre-configured networks or mobile data.

Resolution

To establish an Internet connection on a locked device, you can:

  • Connect the locked device to a previously configured Wi-Fi network.
  • Insert a SIM card with mobile data, if the SIM control policy policy isn’t enabled.

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