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Unable to enroll device in a UEM

Last updated March 11th, 2025

Categories:

Environment

  • Knox Guard
  • Galaxy S25 devices and newer
  • Android Enterprise

Overview

When enrolling a device into a UEM, you may encounter an issue where the enrollment fails.

For Galaxy S25 devices, the following error is displayed:

“Can’t set up device” : Contact your IT admin for help

For non-Galaxy S25 devices manufactured with Android 15, the following error is displayed:

“Work profiles blocked” : For security reasons, you can’t create or add work profiles to this device

Cause

Devices enrolled in a financing program using Knox Guard restrict Android Enterprise provisioning by default, and require consent from the financing program operator to proceed.

To check if Knox Guard is enrolled on your device:

  1. On your device, tap Settings > About phone > Status information > Device Services.
  2. Check if Knox Guard is enabled.

Resolution

To resolve the issue, please contact the financing operator. If you cannot find the financing operator, contact knoxguard@samsung.com.

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