Back to top

Support app unable to launch from lock screen

Last updated August 7th, 2024

Categories:

Environment

  • Knox Guard

Overview

After adding a support app in Knox Guard, you might encounter an issue where the app is unable to launch from the lock screen.

Cause

The method setShowWhenLocked() is used to configure whether an app can run on the lock screen of a device. Apps that don’t call this method with a True value can’t launch from the lock screen.

Resolution

To allow a support app to launch from the lock screen, the setShowWhenLocked() method must be called with its parameter value set as True in the app.

Is this page helpful?