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Device unable to complete campaign with multiple updates

Last updated December 15th, 2023

Categories:

Environment

  • Knox E-FOTA
  • Galaxy devices running Android 9 (Knox API level 3.3) and higher

Overview

When starting a campaign with multiple updates, some users might encounter an issue where the device can’t complete the campaign.

Cause

After the first restart in the campaign, the files and user data become encrypted. Since the files and data are not decrypted, the Knox E-FOTA agent is unable to continue with the campaign.

Additionally, File-based encryption enables the feature Direct Boot, allowing encrypted devices to boot straight to the lock screen. This feature prevents the Knox E-FOTA agent from continuing with the campaign.

Workaround

To resolve the issue, device users must ensure the devices are unlocked before the Knox E-FOTA agent can continue with the campaign. This can be accomplished by either removing the lock screen or manually unlocking the device.

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