Error 710 - Device focused on pinned app

Last updated December 2nd, 2025

Categories:

Environment

  • Knox E-FOTA
  • Mobile device management (MDM)

Overview

When you’re using Knox E-FOTA on your devices, the campaign first downloads the necessary firmware to your device. When the campaign attempts to install the new firmware, the installation fails and you may encounter the following error:

Error 710 - Device focused on pinned app.

Cause

This error occurs when the device is focused on a pinned app, typically because the device is in a dedicated mode like Kiosk mode, which restricts app functionality to only approved apps. Knox E-FOTA can’t perform firmware installation and updates because it hasn’t been added to the approved app allowlist.

Resolution

To resolve the issue, ensure you add the Knox E-FOTA client app to the dedicated device mode allowlist through your EMM.

For more details, refer to your EMM’s documentation on adding Knox E-FOTA to the allowlist of devices operating in Kiosk mode or Lock Task mode.

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