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Unable to add Knox Manage device groups to Knox E-FOTA

Last updated October 4th, 2024

Categories:

Environment

  • Knox Manage
  • Knox E-FOTA

Overview

When adding a device group from Knox Manage into Knox E-FOTA, you might encounter the following error:

Failed to connect EMM [Client ID]

Cause

This error occurs due to different password character restrictions between Knox Manage and Knox E-FOTA. In Knox Manage, when you create an API Client ID password, you are allowed — and required — to use special characters. Some of these special characters, though valid in Knox Manage, are not accepted in Knox E-FOTA.

The following table shows the special characters allowed and not allowed in Knox E-FOTA:

Allowed Not allowed
* / _ ( ) & % $ # @ ! " ’ ’ \ | = ? / { } [ ] ~ ; : . , < > ^ + ¨ ¹ ² ³ £ ¢ ¬ ₢ ´ ` § ° ª º

If the Knox Manage API Client ID password contains any of the characters not allowed by Knox E-FOTA, then an EMM connection can’t be established and a Knox Manage device groups can’t be added.

The Knox E-FOTA team is aware of the issue, and hopes to allow all characters in a future release.

Workaround

To resolve the issue, you must modify the client ID password in Knox Manage to omit any special characters not allowed in Knox E-FOTA.

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