Unable to reconnect Knox E-FOTA with an EMM after updating credentials
Last updated February 22nd, 2024
Categories:
Environment
- Knox E-FOTA
- EMMs
Overview
After updating the client ID or password on your EMM tenant, you might encounter an error where reconnecting the EMM to Knox E-FOTA with the updated credentials fails with the following error:
Failed to connect EMM username.
Failed to connect EMM username. Please try again and if the problem persists, contact Samsung Knox Support.
Cause
The Knox E-FOTA team has identified an issue with the logic that updates the credentials.
The team is working on a fix and hopes to include it in the Knox E-FOTA 24.04 release.
Workaround
If you’re experiencing this issue, you must disconnect your EMM, then connect with the updated credentials:
- On the Knox Admin Portal, go to Knox E-FOTA > EMM groups.
- Click ACTIONS > Download groups as CSV, then click DOWNLOAD to confirm. The current list of groups and assigned campaigns is saved to your device.
- Click ACTIONS > Disconnect EMM, then click DISCONNECT to confirm.
- Connect your EMM to Knox E-FOTA with your updated credentials, and add all device groups that were previously synced. The procedure for this process depends on your EMM. Consult your EMM’s documentation for more information.
- For each device group, assign the campaign that was previously assigned.
- Click Sync now.
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