Back to top

EMM group sync unavailable

Last updated April 1st, 2024

Categories:

Environment

  • Knox E-FOTA connected to an EMM

Overview

If Knox E-FOTA is connected to your EMM console, you might encounter an issue where the EMM group sync feature is unavailable on the Knox E-FOTA console. On the console, the following warning is displayed:

EMM group sync features are unavailable because your data is being managed outside Knox E-FOTA.

If the EMM group sync is unavailable, all EMM groups stop syncing, and the EMM instances are disconnected from Knox E-FOTA.

Cause

Knox E-FOTA communicates bi-directionally at half-duplex with your EMM, meaning it can do one of the following at a time:

  • Pull device information from your EMM
  • Push device information to your EMM

Under normal operation, the communication remains half-duplex. However, if the system operates at full-duplex, and both pushes and pulls at the same time, the channel breaks down and produces unpredictable or undefined results.

To prevent instability issues, the EMM group sync feature has been made unavailable if Knox E-FOTA is connected to your EMM.

Workaround

To use the EMM group sync feature, you must first revoke your EMM consent from the Knox Admin Portal, then reconnect your EMM to Knox E-FOTA.

This procedure allows Knox E-FOTA to pull device information from your EMM, but prevents your EMM from receiving device information from Knox E-FOTA.

First, revoke your consent:

  1. On the Knox Admin Portal, click on your account icon. Click Settings.
  2. Click MANAGE EMM CONSENT.
  3. Select your EMM.
  4. Click REVOKE ACCESS, and confirm the action.

After revoking consent, reconnect your EMM to Knox E-FOTA. The procedure for this process depends on your EMM.

Is this page helpful?