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Device unable to complete enrollment

Last updated December 1st, 2023

Categories:

Environment

  • Knox E-FOTA
  • EMMs

Overview

When enrolling a device in Knox E-FOTA, you might encounter an issue where the enrollment process screen becomes stuck at 25%. The enrollment flow then exits without completing.

Cause

There might be several reasons why the enrollment process can’t continue:

  • There are no license assignments available for the device.
  • The device is having issues with downloading or installing the package com.samsung.android.knox.efota.plugin.
  • The device’s IMEI or serial number hasn’t been uploaded or synced to Knox E-FOTA.

Resolution

To resolve the issue, you must ensure the following:

  • The package com.samsung.android.knox.efota.plugin isn’t blocked by your EMM. Please consult your EMM’s documentation for information on how to verify and remedy this.
  • The device is connected to the internet.
  • The device’s IMEI or serial number was added to the Knox E-FOTA console.
  • The packages com.samsung.android.knox.efota and com.samsung.android.knox.efota.plugin are added to your Device Admin allowlist. Please consult your EMM’s documentation for more information.

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