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Error 91014 — Unable to add app to ProKiosk mode home screen

Last updated August 10th, 2023

Categories:

Environment

  • Knox Configure
  • ProKiosk mode

Overview

When adding an app to the ProKiosk mode home screen with the Add to Multi-App Kiosk home action, users may encounter an issue where the app fails to be added. The Knox Configure device log contains the following error:

Error: Warning (91014): Unable to create kiosk shortcut(s)

Cause

An app must be pre-installed to be successfully added to the ProKiosk mode home screen. The app is not considered pre-installed if it meets any of the following criteria:

  • App has been deleted from the device
  • App package name is invalid when adding to Add to Multi-App Kiosk home
  • App is from the Google Play Store and is not pre-installed

Apps added to a Knox Configure profile through the Google Play Store are not considered pre-installed. After Knox Configure enrollment is complete, the device user must tap the app shortcut on the device to complete the installation from the Google Play Store.

If the app is not pre-installed, then attempting to add the app to the home screen will fail.

Resolution

If the app is not pre-installed, the app APK must be uploaded to Knox Configure. If the APK file can’t be added, users must manually install the app from the Google Play Store either before or after device enrollment.

To manually install the app before enrolling the device:

  1. Start the device.
  2. Install the app from the Google Play Store.
  3. Assign the Knox Configure profile to the device.
  4. Open the device browser and go to configure.samsungknox.com.
  5. Tap FIRST-TIME ENROLLMENT.
  6. Complete the enrollment process.

To manually install the app after enrolling the device:

  1. In the Knox Configure profile, ensure the app shortcut is removed from the Multi-App Kiosk home screen.
  2. Start the device and enroll it in Knox Configure.
  3. Exit ProKiosk mode by holding the power button and entering the passcode set in the Knox Configure console.
  4. Install the app from the Google Play Store.
  5. In the Knox Configure profile, add the app to the Multi-App Kiosk home screen.
  6. Push a profile update.

Additional information

Create a Knox Configure profile

About ProKiosk mode

Knox Configure device enrollment

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