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Cannot set background image (Failed to configure | 51010)

Last updated July 26th, 2023

Categories:

Environment

  • Knox Configure (KC)

Overview

Some administrators are reporting that they are unable to set a background wallpaper on a device in KC, as the following error message appears:

Failed to configure | 51010
Error 51010: An error occurred with setWallPaper in your profile. Check the configuration items in your profile and retry.

Cause

There is a device administrator application that is restricting the wallpaper change, even if the feature is enabled in KC. As device administrator applications include device management solutions, if the device is enrolled in two management solutions, the most restrictive configured policy applies.

Resolution

If the device is also enrolled in more than one management solution, check the restrictions in each solution profile. Please ensure that in one solution, the policy that enables wallpaper changing is not restricted. In any additional solutions, the wallpaper change policy should be set as unconfigured.

For example, if the device is enrolled in Knox Manage (KM) and KC, set the policies in KM and KC as shown below:

  • KM: Change wallpaper: N/A
  • KC: Prevent end users from changing the Home screen and Lock screen wallpapers: Enabled

After ensuring that the policies are updated, try changing the device’s wallpaper in KC again.

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