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An error occurred with a system app in your profile

Last updated December 24th, 2024

Categories:

Environment

  • Knox Configure
  • Knox Mobile Enrollment

Overview

When enrolling your device fleet with Knox Configure and Knox Mobile Enrollment, you may encounter an issue where the Knox Configure profile fails to apply to the device due to the following 51010 error:

Error 51010: An error occurred with API name, application name, content file name in your profile. Check the profile configuration and retry.

Cause

With Knox Mobile Enrollment, if the Disable system app option is selected, Knox Configure is unable to apply a profile containing policies related to system apps.

Resolution

In Knox Configure, view the device log for your affected device. Under EVENT, the policies causing the configuration to fail are listed. To resolve the issue, you must remove these policies.

Alternatively, to resolve the issue without removing any policies in Knox Configure, enable system apps in Knox Mobile Enrollment:

  1. In Knox Mobile Enrollment, modify the existing profile to enable system apps.
  2. Factory reset the device.
  3. Re-enroll the device.

If the issue persists, submit a support ticket.

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