Can’t add a new application to the library
Last updated November 14th, 2024
Categories:
Environment
- Knox Configure
Overview
IT admins may encounter the following error when entering a URL of an application to add to the library in Knox Configure:
The application already exists. [40001]
This issue occurs even if the application is new or hasn’t been added.
Cause
When entering a URL of an application, any parameters with the key id
is used to identify the app. If there are multiple parameters with the key id
, the validation process fails and the application is incorrectly identified.
For example, the following URL would lead to a validation failure: https://play.google.com/store/apps/details?id=com.sec.android.app.sbrowser&hl=pl&pcampaignid=web_share
This issue commonly occurs when the user enters the link generated by the Share button on Google Play.
Resolution
To resolve this issue, you must enter a URL without any additional id
parameters.
An example of a correct URL for an application is as follows: https://play.google.com/store/apps/details?id=com.sec.android.app.sbrowser
You must not use the Share button on Google Play and instead enter the URL as shown on the address bar of your browser.
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