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Unable to reassign devices to a renewed license

Last updated November 10th, 2023

Categories:

Environment

  • Knox Configure
  • Non-transferable Per Device license for Dynamic edition

Overview

If you renew a Knox Configure Dynamic Edition Per Device license after the 30 day grace period, you may encounter the following error when attempting to reassign devices that were previously activated on the license:

Failed to assign devices
Could not assign profile profile name to device(s). Please see details for errors. If the problem persists, contact Samsung Knox Support.

When downloading the details, the following description is shown:

Failed to assign devices

Cause

For fleets with 1000 or more devices, there’s an issue with the logic that checks if there are enough assignments left on the license.

Resolution

First, ensure that the device was previously activated on the license before the license expired:

  1. On the Knox Admin Portal, go to Licenses.
  2. Click Manage license keys.
  3. Click Device Status.
  4. Enter your Knox license key and device IMEIs associated with that license.
  5. Click CHECK STATUS.

If the devices were previously activated on the license, they can be reassigned.

Devices must be assigned in bulk to the correct profile in batches of 1000 or less.

Additional information

For more information about how to manage Knox Configure licenses, refer to Manage licenses.

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