Knox Capture launches black screen on camera scan trigger
Last updated August 15th, 2025
Categories:
Environment
- Knox Capture
- Samsung Keyboard
Overview
When tapping the Scan icon on the Samsung Keyboard toolbar, floating action button, or pressing the hardware key, you may encounter an issue where the Knox Capture camera launches a black screen or doesn’t launch. You may also notice the camera doesn’t work with an app configured in a scanning profile.
Cause
This issue may occur when the device user or the device’s application management feature adds Knox Capture to its Sleeping apps or Deep sleeping apps. When the Knox Capture app is in sleep or deep sleep mode, the scanning camera can only launch if the device user manually opens the app.
Resolution
To resolve this issue, you can remove Knox Capture from Sleeping apps or Deep sleeping apps:
- On the device, navigate to Settings > Device care > Battery > Background usage limits.
- Go to Sleeping apps or Deep sleeping apps and remove Knox Capture from the app lists.
To ensure Knox Capture doesn’t enter sleep or deep sleep mode in the future, you can add Knox Capture to the Battery optimization allowlist using Knox Service Plugin through your MDM.
Before applying this policy, the app must be removed from Sleeping apps and Deep sleeping apps.
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