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Auto delete unused profile after (months) policy automatically set to 3 months

Last updated January 8th, 2025

Environment

  • Knox Authentication Manager v1.7 Managed App Config policies showing in your UEM console

Overview

Starting with the update to Knox Authentication Manager v1.7 in your UEM console, you may encounter an issue where pushing a profile to a device automatically sets the Auto delete unused profile after (months) policy to 3 months, regardless of the value you set.

Cause

There are multiple reasons for this issue:

  • If any profile configured in Knox Authentication Manager v1.7 is pushed to devices running older versions of the app, such as Knox Authentication Manager v1.6 or earlier versions, a default value of 3 months is set for the Auto delete unused profile after (months) policy.
  • The Knox Authentication Manager v1.7 release includes an update to the Auto delete unused profile after (months) policy. To allow for improvements in future releases, the policy field accepts strings consisting of alphanumeric characters. If a non-numeric character is included in the field, a default value of 3 months is set for the policy when the profile is pushed to the device.

Resolution

There are multiple methods to resolve the issue:

  • If your device is running Knox Authentication Manager v1.6 or earlier versions of the app, you must update your device to the latest version of the app.
  • If non-numeric characters are included in the policy field, ensure only numerical values from 1-36 are used when setting the Auto delete unused profile after (months) policy in your UEM console.

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