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Blank Screen During Enrollment

Last updated July 19th, 2024

Categories:

Environment

  • Knox Asset Intelligence
  • Knox Manage
  • Android Enterprise

Overview

After a device enrolls in Knox Manage, and the Knox Asset Intelligence app is launched for the first time, some users may encounter an issue where a blank screen displays on their device without any prompts. However, on the Knox Asset Intelligence console the device status is active and collecting data.

Cause

Starting from Knox Manage 24.04, the Location policies were renamed and reorganized. If you have the Location Settings policy configured to either Force on or Force off, then the Improve Location Accuracy prompt from Google is blocked from displaying on the device — leading to a blank screen.

Workaround

To prevent the blank screen from showing on devices, you must change the Location settings policy:

  1. In the Knox Manage console, go to Profile.
  2. Click Modify profile.
  3. Expand the Android Enterprise > Location policy drawer and set Location Settings to either Allow user to configure or Allow user to configure and prompt for location accuracy.
  4. Click Save & Assign to push the profile to your device group.

After pushing the profile, device users can see and interact with the Improve Location Accuracy prompt. After they accept or decline the prompt, the Knox Asset Intelligence enrollment screen loads on the device. You can then go back to Knox Manage to set the Location Settings policy to either Force on or Force off on the Knox Manage console.

If you later factory reset the device and again want to show the Improve Location Accuracy prompt to the device user, set the Location Settings policy to Allow user to configure or Allow user to configure and prompt for location accuracy.

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