Cannot invite admin - Requester cannot access user error
Last updated March 25th, 2026
Categories:
Environment
- Knox cloud services
- Samsung Account for Business
Overview
When inviting an admin to your Knox tenant, you may encounter the following error message:
Requester cannot access user; userId=xxxxxxxxxx
Cause
This error may occur when the admin you’re inviting to your Knox tenant is already registered in Samsung account for Business but hasn’t been assigned to the same service location as the super admin of the Knox tenant.
Resolution
To resolve this error, you need to verify that both the super admin and the invited user are assigned to the same Samsung account for Business service location. To do so:
- Sign in to the Samsung account for Business console.
- Navigate to the Locations page.
- On the service location entry where the super admin’s assigned, click > View users.
If the user isn’t in the same location as the super admin, you’ll need to edit the user’s location. For detailed steps, see Edit user locations.
Additional information
If you have any other questions, you can submit a support ticket.
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