Knox account application rejected after Samsung account for Business approval
Last updated March 2nd, 2026
Categories:
Environment
- Knox cloud services
- Samsung Account for Business
Overview
When applying for Samsung Knox, you may encounter an issue where your Samsung account for Business application is approved, but your Knox account application is rejected.
Cause
Your Knox account may have been rejected because you registered using a personal email instead of a business email.
Although you can apply for a Samsung account for Business using a personal email domain, such as @gmail.com or @yahoo.com, Samsung Knox has stricter validation requirements and rejects applications that use personal email domains instead of verified business email addresses.
Resolution
To resolve the Knox registration issue:
- Submit a support ticket to have your rejected Knox tenant deleted from the system. Include your Customer ID or Samsung account for Business Account ID in the ticket.
- Navigate to the Samsung account for Business console, and add a new a user using a verified business email domain (not @gmail.com or other personal domains).
- Go to SamsungKnox.com.
- In the top-right corner, click Get Started and enter the business email address you added in step 2.
- On the Sign up for Samsung account for Business page, click Sign in and continue the registration process.
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