Devices occupying seats on multiple licenses
Last updated February 3rd, 2026
Categories:
Environment
- Knox Admin Portal
- Knox cloud services
- Knox Suite - Enterprise Plan
Overview
On the Knox Admin Portal, you may notice some devices are incorrectly assigned to multiple licenses, occupying extra license seats. When you try to reassign these devices to free up seats for other devices, the Reassign license key action doesn’t work.
Cause
Some devices may be active across multiple license keys for the same Knox service. The system treats each license assignment as a separate seat, resulting in the same device occupying multiple seats at once.
This also prevents the Knox Admin Portal from displaying accurate available license counts and prevents admins from assigning licenses to new devices, even when sufficient total licenses exist.
Resolution
As of August 2025, the Samsung Knox team released a fix to resolve this issue.
The Reassign license key action can now resolve duplicate device issues and free up any occupied seats. However, ensure you don’t select too many devices at once when re-assigning licenses — you’ll need enough available seats to move all the selected devices. As such, the system only displays the licenses capable of accommodating all these devices.
To resolve this issue:
- On the Knox Admin Portal, go to the Devices page.
- Select only the duplicated devices occupying multiple license seats.
- Click ACTIONS > Reassign license key.
- Select a license from the available options — the system only displays licenses with a sufficient number of available seats.
- Click Assign.
On this page
Is this page helpful?