Back to top

No devices can be assigned with the selected license key

Last updated March 11th, 2025

Categories:

Environment

  • Samsung Care+ for Business

Overview

When assigning a Samsung Care+ for Business license to a device, you may encounter one of the following error messages:

There are no devices that can be assigned with the selected license key.

An error has occurred. Please try again later.

Cause

When your Samsung Care+ for Business license key was generated, an error may have occurred where the associated product ID doesn’t include your device model(s).

Resolution

Please contact the Samsung Care+ for Business team to solve this issue by submitting a support ticket. In your ticket, please include the following information:

  • Subject: No devices can be assigned with the selected license key
  • Description: Your license key and the device model(s) you’re unable to assign.

Is this page helpful?