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“Security policy prevents turning on device administrators” shown when launching apps

Environment 

  • Knox Manage (KM)
  • Android Enterprise (AE) Device Owner (DO) mode
  • Knox Service Plugin (KSP)

Overview

When launching an app on a KM-managed device with KSP enabled, some users are receiving the following error:

Security policy prevents turning on device administrators

Cause 

If KSP is enabled in the KM console, it will block any application requesting device admin permissions by default.

Resolution

This issue was addressed and fixed in the Knox Manage v20.2 release. You must add the app receiving the error in the device admin whitelist:

  1. In your KM console, select Profile.
  2. From the Samsung Knox Android Enterprise tab, select System > Whitelisted Device Admin policy.
  3. Select Apply, then Add the app receiving the error.
  4. Save and apply your changes.

Additional information