Menu

FAQs

General

Which devices support the Knox POS SDK?

As of release, only select flagship and rugged devices support the Knox POS SDK. These include:

  • Smartphones: S22, S21, XCover6 Pro.
  • Tablets: TabActive4 Pro.

The scope of eligible devices will expand to cover select devices supported by Android OS 13 and higher and Knox version 3.9 and higher.

NOTE — Availability of the Knox POS SDK may vary by country or region.

Which versions of Android are supported by the Knox POS SDK?

Android versions 13 and higher are supported by the Knox POS SDK.

Which versions of Knox support the Knox POS SDK?

The Knox POS SDK is available from Knox v3.9 and higher.

Do I need the Knox SDK to use the Knox POS SDK?

While the Knox SDK and the Knox POS SDK are different products, the Knox SDK is a prerequisite for the Knox POS SDK. You must first install the Knox SDK as it provides some of the functions required to process mPOS.

What kind of accessories do I need to use the Knox Platform for POS in a device?

You don't need any accessories to use the Knox Platform for POS.

License

Do I need a license to start using the Knox POS SDK?

Yes. You must have a license for both the Knox SDK and Knox POS SDK.

How do I get a license for the Knox POS SDK?

You must be a member of the Knox Partner Program with access to Knox Developers resources. Please refer to Get license for details.