Device locked with ‘Workspace License Expired’ error after updating VMware Workspace ONE® Intelligent Hub
Last updated February 21st, 2023
Categories:
Environment
- Active KLM Legacy license (KLM03~) or Samsung Galaxy Enterprise Edition (EE) legacy license (KLM07~)
- Knox Platform for Enterprise
- VMware Workspace ONE® Intelligent Hub
- Android 10 and lowe
- Android Enterprise fully managed devices
Overview
After the VMware Workspace ONE® Intelligent Hub update to v22.11, some users encountered an issue where the device is locked with the error:
Workspace License Expired
Cause
Previously with versions lower than v22.11, VMware Workspace ONE® Intelligent Hub would activate Samsung’s Enterprise License Management (ELM) license key. The ELM key grants access to Knox Standard license features. Additionally, users or other third-party apps can activate the KLM or EE Legacy license for access to Knox Premium features.
In this case, and for other apps that activate legacy ELM, KLM, or EE license keys, these keys grant permissions to the VMware Workspace ONE® Intelligent Hub that allow it to enable access to Knox Premium features.
Starting with VMware Workspace ONE® Intelligent Hub v22.11, the ELM license key activation was replaced with the Knox Platform for Enterprise (KPE) Standard key. Activating the KPE Standard license causes the Knox Premium permissions to be revoked, causing the device to unintentionally lock and display the error Workspace License Expired
.
As of October 2018, Samsung replaced the ELM license key with the KPE Standard key. To improve security measures, the KPE Standard key provides access to app-specific permissions instead of device-wide permissions.
Resolution
If a device is locked and shows the Workspace License Expired error, it can only be restored through a factory reset.
For devices that are at risk of being locked by the KPE Standard license, activating a KPE Premium license key will avert this issue. If the VMware Workspace ONE® Intelligent Hub activates a KPE Premium key on the device instead of a KPE Standard key, the device will not lose the Knox Premium permissions and will remain unlocked.
Before activating the KPE Premium key, ensure that the KLM Legacy license (KLM03~) or EE legacy license (KLM07~) is currently activated.
To check if there is an active legacy key:
- Sign in to the Knox Admin Portal.
- Click Licenses to view your licenses.
To generate and activate the KPE Premium key in the VMware Workspace ONE® UEM console:
-
Enter your KPE Premium license key in the VMware Workspace ONE® UEM console to unlock the device.
Consult the VMware Support team if any unexpected behavior arises.
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