- *BASICS*
- The Knox Ecosystem
- White Paper
- Samsung Knox Portal
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- *FOR IT ADMINS*
- Knox Admin Portal
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- Introduction
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- Before you begin
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- Getting started with Knox Capture
- Step 1: Launch Knox Capture
- Step 2: Create a scanning profile
- Step 3: Select apps and activities
- Step 4: Configure the scanner
- Step 5: Set keystroke output rules
- Step 6: Test apps in your configuration
- Step 7: Share your configuration
- Step 8: Deploy Knox Capture in Managed mode
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- Video: Getting started with Knox Manage
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- Introduction
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- *FOR RESELLERS*
- Knox Deployment Program
- *FOR MANAGED SERVICE PROVIDERS*
- Knox MSP Program
Device stops receiving SMS/Text messages after FOTA update
Environment
- Knox Platform for Enterprise (KPE)
- Galaxy A-series
- Galaxy J-series
- Android Enterprise (AE) Device Owner (DO) mode
Overview
On Galaxy A-series and Galaxy J-series devices on AE DO mode with a Knox Premium license, newly-received SMS or text messages do not appear in the default SMS/text application after a Firmware-Over-The-Air (FOTA) update. In the device's notification bar, there is no notification shown for any incoming SMS or text messages.
Cause
The device's OS is unable to find the default SMS/Text application. The dumpstate log below shows the error:
11-25 17:04:58.525 radio 5016 5291 E GsmInboundSmsHandler: Unable to find carrier package: [], nor systemPackages: [] 11-25 17:06:05.334 1000 4454 4473 W BroadcastQueue: Background execution not allowed: receiving Intent { act=android.provider.Telephony.SMS_DELIVER flg=0x18000010 (has extras) } to com.samsung.android.messaging/.ui.receiver.smsmms.DefaultSmsAppSmsReceiver
Resolution
This issue is fixed for all versions of Android 10.
Workaround
If your Galaxy A-series or J-series device is not receiving SMS/Text messages, perform a factory reset to resolve the issue.
Additional information
This issue has been confirmed for all A50 devices updating from firmware version:
- A505WVLU2ASH2 to A505WVLU2ASJ1
- A505WVLU3ASK2 to A505WVLU3ASK23