Menu

Why is the Knox Workspace container not deleted after unenrolling from the EMM?

[Environment]
Samsung Android devices on N OS.
All Knox versions

[Issue]
After unenrolling a device from the EMM, the Knox Workspace container is not deleted. On subsequent enrollment, a second Knox Workspace is created. Unenrolling the device from the EMM does not remove either of them.

[Cause]
Two key services used for unenrollment were hung in a locked state, preventing them from removing Device Admin. This prevents the Knox Workspace from being removed.

[Resolution]
There is a fix is available in device software releases after July 2017. Update your device to the latest OS.
Share it: