Back to top

Unable to install Samsung Calendar app

Last updated November 6th, 2023

Environment

  • Android Enterprise
  • Samsung devices running One UI 5.1.1 and higher

Overview

When enrolling a device, users might encounter an issue where the Samsung Calendar app can’t be installed from your EMM.

Cause

Before One UI 5.1.1, the Samsung Calendar app was considered a system app, and was able to be installed with the enableSystemApp() method. As of One UI 5.1.1, the Samsung Calendar app is no longer considered a system app, and is instead available from Google Play.

Resolution

To install the Samsung Calendar app on the device, the app must be deployed through Managed Google Play. To do so with Knox Manage, see Add apps using Managed Google Play. For other EMMs, consult their documentation.

Back to KBAs

Is this page helpful?