Menu

Minimum Requirements

To use KME Direct, you need:

  • Samsung Knox access—The IT admin needs a valid Samsung and Knox.com account to access and use the KME Direct PC application. For more information, see Create your Samsung account.
  • Computer used to run the PC application—The IT admin needs a computer with the following system requirements:
    • Operating system—A laptop or desktop computer running Windows 10.
      NOTE—While the KME Direct application may run on devices running versions of Windows lower than Windows 10, you may experience compatibility issues.
    • Browser—A supported browser, either Mozilla Firefox, Google Chrome, or Internet Explorer.
  • Target devices—Additionally, the target devices that your device users are setting up using KME Direct must match the following specifications:
    • Knox version—Currently, you can only use KME Direct on Samsung Knox devices running Knox version v3.7.1 or higher.
    • Knox Service Plugin App—The target device must download and install the Knox Service Plugin (KSP) app before using KME Direct. The IT admin must upload the KSP Agent's APK file to the internal server on their organization's network. When the device user scans the QR code, the device automatically downloads and installs KSP, and then continues on with the KME Direct set up process. For more information about KSP, see Knox Service Plugin Admin Guide.
Share it: