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MSPs cannot migrate KM customers who have an existing KM tenant

Environment

  • Knox Managed Service Provider (MSP)
  • Knox Manage (KM)

Overview

You may encounter an issue when trying to migrate an existing KM customer to the Knox MSP Portal where the Knox Manage checkbox is grayed out and cannot be selected.

The issue is encountered with the following workflow:

Issue path: Knox MSP Portal Customers tab > ADD CUSTOMER > Migrate an existing Samsung Knox customer > add Knox Customer ID

Issue path image

Cause

You cannot migrate an existing KM tenant to the Knox MSP Portal because KM tenants with duplicate emails are not accepted. This is because emails addresses are a unique key used to distinguish customer admins.

This issue occurs in the following situations:

  1. If multiple admins in a KM tenant have the same email address.

    For example, KM tenant abc.com has 2 admins — one admin with account admin@abc.com and another admin with account admin@abc.com.

  2. If multiple admins in multiple KM tenants have the same email address.

    For example, ad admin with account admin@abc.com exists in KM tenants abc.com and def.com.

Resolution

To avoid this issue, ensure that there are no KM admins with the same email address. If there are any KM admins with the same email you must delete these KM admins, then submit a support ticket that describes your issue.