Menu

Minimum requirements

Kiosk mode is only available for Android OS.

Android OS version Samsung Android Legacy Samsung Android Enterprise Fully Managed Device Non-Samsung Android Legacy Non-Samsung Android Enterprise Fully Managed Device
Android 5.0 to 8.0
  • Single App kiosk
  • Multiple App kiosk
  • Kiosk Browser
  • Single App kiosk
  • Multi-app kiosk
  • Kiosk Browser
Not supported
  • Multi-app kiosk
  • Kiosk Browser
Android 9.0 or later
  • Single App kiosk
  • Multi-app kiosk
  • Kiosk Browser
  • Single App kiosk
  • Multi-app kiosk
  • Kiosk Browser
Not supported
  • Single App kiosk
  • Multi-app kiosk
  • Kiosk Browser

NOTE—Knox Manage provides Single App Kiosk with Google managed apps for Android Enterprise devices with version 9.0 (Pie) or higher.