Menu
"/>

Unable to upload Single-App Kiosk launcher app

Environment

  • Knox Manage (KM)
  • Single-App Kiosk mode

Overview

After the Knox Manage (KM) v20.11 update, it is no longer possible to add a Launcher app to Single-App Kiosk mode.

Cause

Changes were made to the Single-App Kiosk mode concept in KM v20.11, which removed the capability of adding a Launcher app.

Resolution

To add a Launcher app to Single-App Kiosk mode, you must first add the app to the Application console:

  1. In your KM console, go to Application > Add > Internal App, and upload the app.
  2. Go to Kiosk > Add > Single App Kiosk, and drag the app into the kiosk wizard.

We also recommend you request the app developer to remove the launcher property from the app, as it is no longer required to be added to Single-App Kiosk mode.