Device unexpectedly enters a locked state
Last updated September 19th, 2024
Categories:
Environment
- Knox Manage
- Knox Manage agent 24.06
Overview
You may notice that some devices unexpectedly enter a locked state with the following error:
The device has been locked by Knox Manage because an OS compromise has been detected.
The device user is prompted to enter an unlock code.
Cause
This issue occurs as a result of a security measure that was previously implemented in Knox Manage.
Resolution
A fix for this issue is included in Knox Manage agent version 24.06 (2.7.1.17).
To resolve the issue, you must first unlock affected devices on the Knox Manage console:
- In the Knox Manage console, click Device.
- Select the devices, then click Device Command.
- Click Device > Unlock Device.
- Click OK to push the command to your device fleet.
Next, update the Knox Manage agent on your device fleet:
- While in Device Command, click Knox Manage > Update Knox Manage Agent.
- Click OK to push the command to your device fleet.
Device users can also manually update the Knox Manage agent after the device is unlocked:
- Launch the Knox Manage agent app on the device.
- Tap About > Update. Google Play opens.
- Proceed to update the Knox Manage agent on Google Play.
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