- Basics
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- Getting started with Knox Capture
- Step 1: Launch Knox Capture
- Step 2: Create a scanning profile
- Step 3: Select apps and activities
- Step 4: Configure the scanner
- Step 5: Set keystroke output rules
- Step 6: Test apps in your configuration
- Step 7: Share your configuration
- Step 8: Deploy Knox Capture in Managed mode
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Unable to change app icon of custom app
Environment
- Knox Configure (KC)
Overview
In KC, when an administrator tries to change a custom app's icon in a profile that was set by a different administrator, the icon is not changed. The following error is shown in the device logs:
11-22 11:30:44.302 1000 1213 7317 D ApplicationPolicy: changeApplicationIcon:packageName com.samsung.android.messagingcalled from :10167 11-22 11:30:44.304 1000 1213 7317 E ApplicationIconDb: updateApplicationIcon(): invalid ownerUid
Cause
In KC, an icon set by one administrator cannot be changed by a second administrator. This behavior is by API design.
Resolution
To change the app icon, please ensure that the original administrator who set the app icon makes the update in the KC profile.
Alternatively, Role-Based Access Control (RBAC) allows a KC super admin to assign specific permissions to individual admins. For instructions on how to configure admin permissions, see Administrators and roles.
Additional information
For more information on how KC changes app icons, see the Knox API documentation.