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Wearable device is unable to connect to a specified Wi-Fi network after password is updated

Environment

  • Knox Configure for Wearables (WKC)

Overview

In KC, after a device is configured on a profile with a SSID name and password specified in Profiles > device profile > Device connectivity > Network (optional), the password is not properly pushed to the device if it is updated. The wearable device is then unable to connect to the Wi-Fi network specified in the profile.

Cause

The API used to determine if the Wi-Fi settings need a new password incorrectly returns "false" if the SSID and password configuration was previously saved. The incorrect value is returned even if the password has been changed.

Resolution

A fix for this issue is available in WKC 1.28.3. If the device is currently configured in KC, please update to the latest KC client.

Please reconfigure your device by pushing an update in KC, or pulling the latest profile by following the below steps:

  1. On your device, go to Settings > About Device > Software Info.
  2. Select Knox Configure > Apply latest profile.

Workaround

In the KC console, under Profiles > device profile > Device connectivity, use Advanced Wi-Fi Settings when specifying an SSID Name and password for a device instead of entering it under Network (optional).