Menu

Policy update on Knox supported versions

Environment

  • Knox cloud services

Overview

Starting on March 16, 2022, there is a policy update for Knox products. Although the support for the oldest version is no longer available on every first major release in the year, Knox solutions are supported on the latest five major Android versions.

With this change, we commit to:

  1. Maintain the best-in-class product quality by focusing our resources on the versions that majority of you use.
  2. Enhance the security of Knox products by restricting the supported versions to recent ones that have valid security patches from OS or hardware.

Exceptions

  • Knox Platform for Enterprise is supported from Knox 2.4 and each feature is dependent on the specific Knox version.
  • Knox Manage is supported from seven major Android versions (6-12). To avoid dramatic changes, Knox Manage will take two more years to follow the above policy – targeting to have the same minimum supported version by 2024.
  • Recently released products (i.e. Knox Mobile Enrollment Direct, Knox Asset Intelligence, Knox Capture, etc.) are supported on less than five OS versions now. These products usually have the latest version as minimum supported version when they are launched.

Supported versions for each Knox solution: (as of March 2022)

The following table lists Knox products’ minimum supported versions.

Products Minimum supported version
Knox Platform for Enterprise Android 5.0.1 (Knox 2.4)
Knox Service Plugin Android 9.0 (Knox 3.2.1)
Knox Manage1 Android 6.0 (Knox 2.6)
Knox Mobile Enrollment Android 8.0 (Knox 3.0)
Knox Mobile Enrollment Direct Android 11.0 (Knox 3.7.1)
Knox E-FOTA Android 8.0 (Knox 3.0)
Knox Asset Intelligence Android 11.0 (Knox 3.7.1)
Knox Configure Android 8.0 (Knox 3.0)
Knox Guard Android 9.0 (Knox 3.2.1)
Knox Deployment app Android 8.0 (Knox 3.0)
Knox Capture Android 11.0 (Knox 3.7.1)

1 Knox Manage supports multiple platforms outside of Android. For all information regarding the device and platform compatibility of Knox Manage, see Minimum Requirements in the Knox Manage admin guide.

Additional information

To learn more about the policy update, refer to the Policy update on Knox supported versions blog.